MailVision Crosslynx

Пограничный контроллер соединений (Session Border Controller, SBC) Crosslynx - это программный продукт, позволяющий всем оконечным SIP-устройствам проходить NAT независимо от их собственных возможностей по работе с NAT.

Решение Crosslynx соответствует последним спецификациям стандарта SIP RFC 3261 и обеспечивает недорогое, хорошо масштабируемое, полностью резервируемое решение с отказоустойчивой, распределенной архитектурой.

Основные характеристики

  • Базовая функциональность:
    • SIP прокси-сервер
      • SIP Registrar Server
      • SIP Location Server
    • Back to Back User Agent for SIP
    • Back to Back media relay for RTP и RTCP
  • Поддерживаемые NAT и FireWall:
    • Домашние (резидентные) FireWall
    • Мощные корпоративные FireWall
    • Full Cone NAT
    • NAT с ограниченным функционалом (Restricted NAT)
    • NAT с ограничениями по портам
    • Симметричные NAT
    • Многоуровневые NAT всех типов
  • Поддержка VoIP и других типов соединений:
    • Аудио
    • Видео
    • Мультимедиа
    • Обмен мгновенными сообщениями (IM)
    • Информация о наличии SIP-устройств в системе
    • Межоператорский обмен
  • Протоколы сигнализации:
    • SIP (RFC2543, RFC 3261) и расширения SIP
    • SDP (RFC2327)
  • Возможности ретрансляции/проксирования информационных потоков – медиа-протоколы
    • RTP (RFC1889, RFC3550, включая шифрование)
    • RTCP (RFC1889, RFC3550, включая шифрование)
    • Производные от RTP и RTCP (т.е. RFC2833) для DTMF.
  • Учет и авторизация:
    • Передача учетной информации по Radius-интерфейсу
    • Настраиваемый формат записей о звонках (CDR): конфигурирование формата и способа доставки (FTP, HTTP, SSH) средствами XML
  • Безопасность:
    • Списки адресов, с которых разрешен прием вызовов
    • Аутентификация через Radius-интерфейс
    • Встроенная аутентификация
    • STUN-сервер (Simple Traversal of UDP through NATs - optional)
  • Управление:
    • Управление через Web-интерфейс - имеет три уровня:
      • Поставщик услуг: может создавать и администрировать клиентов/домены
      • Администратор домена может настраивать и администрировать пользователей своего домена, и услуги.
      • Пользователь: может изменять свои персональные настройки.
    • Управление Java - JMX
    • SNMP
    • Регистрация событий: доступ, сбои/ошибки, статистика, трассировка
    • API для связи с системами управления сторонних производителей